Not so obvious class names

I came across this today in the Hibernate sources:

An interface that has “Implementor” in its name ? It made my head spin for a while, trying to understand why someone would name it that way. Looking at the class comment didn’t help me much either, in fact quite the contrary :)

Now I’m all for using declarative naming when programming, as it tells you the intent of a component without having to look at it. Therefor i would have no problems using some of the class names mentioned here .

Then again, whoever came up with kFindFolderRedirectionFlagsUseGivenVRefNumAndDirIDAsRemoteUserFolderBit as part of an enum deserves an honorable mention in this list.

No comments: